[SOLVED] Cannot Change Scripts Loading Order

Hi, when I try to drag a script under Settings -> Scripts Loading Order, it doesn’t change the order (just resets back to how it was). Is this bug being fixed? My project is currently broken until I can fix this.

1 Like

I think I managed to work around this by dragging the script down by 1, which actually moved it up 1 each time. After doing this enough times, I was able to drag it freely again to the top. Another note here though, is that the script order seems to randomly change sometimes (ie a script will be moved to the bottom of the list sometimes without changing the script order).

Hi @rdhagan. Thank you for reporting an issue. We can see there is a problem there indeed. It is a bit complicated due to underlying storage where this data is stored. We will be working on solution to resolve it.

Also make sure the debug is NOT is not running, otherwise you wont be able to move not even one script…

There was a changes done recently the way we handle script loading order, and those changes should resolve problems you’ve experienced previously.

@plasmalasgun cheers for note, just check the date of post (it’s more than half a year ;))

in the last few days I had the same problem, scripts preloaded without “debug mode” active does not response to my desired order. I solved that unchecking preload one by one each script, and checking again all of them, one by one, in my desired order. It worked!