[SOLVED] Auto Complete Stopped Working

This morning, autocomplete stopped working for the Playcanvas Code editor.
I tested on 2 different projects & 2 different accounts but no auto complete shows up.
My code compiles and runs fine.

There’s this error in the console of the code editor window

Could this error be from me or is it playcanvas ?

1 Like

Can confirm. Same problem here in Firefox:

That’s interesting, seems to be working fine on two projects I’ve just tested.

I am curious if certain code throws the exception and stops the terner parser.


Can confirm, same error (Windows-Chrome):

@vaios Something for you to look at? :slight_smile:

This is fixed now

Thanks a lot

For some of the legacy words like (‘app’) or (‘rigid body’) etc it doesn’t show at first writing. Any clue why this is happening in the new script editor?

Btw, love the new editor :smiley: sleeeek

Example: see how it doesn’t show (‘mouse’) where in the past it would. Same happened with (‘app’).

Hi @Robotpencil,

Where are you typing that? Seems to be working as expected when added inside a script method:


Works now! Earlier wasn’t working. Weird. Thanks for the check in!

nevermind. Seems like this project is doing some weird stuff in general.

so here is the weirdness.

Trying to add an attribute.

And here is me doing the above issue with mouse.


Hmm, I can’t replicate this unfortunately. Is it only that project that has issues? If so, can you share that project?