[SOLVED] Animation fails to play

I am trying to simply get a test animation playing on this mesh to view it in the editor (no code involved) but I have no idea as to which entity I should put the component onto. I tried everything I can think of (including using the legacy anim component) but no matter I try the anim wont play automatically in the editor.

I can see that the animation seems to work fine in the glb preview window so nothing wrong with the anim itself.

Any ideas?


Are you using the anim component or the animation component?

Are you using the import hierarchy (render component) or the model component?

Hi, I have tried both the anim and Animation(Legacy) components (on the animation-test entity).

When I brought the model in it seems to have already assigned the entity to have a ´Render´ component (to the ´telo´ entity)

Possibly related issue?

Only the Anim Component will work with the Render Component/Import Hierarchy. Ensure that the Root Bone for the Anim Component is on set correctly

Got it working thanks. The problem was the the root bone was not pointing at the correct entity.

As some helpful advise to others that I just figured out you can check if this is correct in the state graph editor without having to run your project. Just click on the state and watch the preview…if only a skeleton is animating (no visible mesh) you probably have chosen the wrong root bone.

Thanks all!