[SOLVED] Ambient Occlusion too subtle?


#1

HI
For some unknown reason, my AO texture plugged into the ambient of the material does not render very well. In fact, the AO is almost invisible. But plugged into the diffuse, everything is ok. The UV channel and the RGB settings in the properties are ok. So I wonder why the shader render my map very subtly ?

AO in the Diffuse texture space (Floor only)

AO in the Ambient texture space. (Floor only)


#2

Hi @atomfreak

The material’s ambient occlusion only affects the scene’s ambient light. Since the ambient in your scene is likely much lower than the directional light, it won’t be very noticeable in the bright areas (like the floor in your screenshot). You should see the effect more clearly on the areas without direct light, like the wall bits in shadow.

If you want to increase the effect of AO in general you can increase the scene ambient (in settings->rendering->ambient color) and decrease the light color.

You could also leave the AO texture in the material diffuse, but that might look strange if you ever add local point or spot lights (because they will also be darkened by the AO).

I’m new to playcanvas, but I hope that helps!


#3

Hi codebon
Thank you for the explanations. It makes sense. I managed to find the right setup.