[SOLVED] All outputs have blue lines/broken!

As of today, all of my projects are now showing blue lines running through them. Its exists on the editor, preview, playcanvas hosted and my own hosted projects. This must be an issue with an included script. I’m paying for a license and I currently have projects out in public. I have also tested loading a demo project which is showing the same issue.

This is a total mess. How did this make it out into the wild??? How can we trust this to be used in production

Screen Shot 2021-02-02 at 3.06.49 pm|690x256

Odd. Just tried three of my projects, and they all seem to be fine. @scrolls_mckenzie are you using any external scripts that may have caused issues? This is an AR project though, does it happen in non-AR projects?

1 Like

Hi @DevilZ

thanks for the follow up

I am working on an AR project and have not included any scripts outside of my normal build which was working fine days ago. I have just logged in to update some content. I have also tried using a demo project in the Explore section which is showing the same.

The only screen which is working is iOS (i dont have an android handy) but all the editor screens and preview outputs on Mac are having issues. I have also tested on multiple browsers. the above image is from Firefox and here is one from chrome which is worse

Just did a load of a demo project called Herbivore which is not AR and is the same issues.

1 Like

Looks like a local/regional issue to me, @yaustar is this an editor bug? I find it quite odd that it happens in some regions and not others. Just to be clear @scrolls_mckenzie, this is only in editor and launch, right? Not in the playcanv.as build links?

For clarity, I’m in Australia.

@DevilZ its in all outputs when viewed on non mobile. I have tested on multiple browsers

  • The preview mode
  • The hosted published mode
  • and the Self hosted published mode
1 Like

So if you download the files, and run index.html in a server, it still happens? :thinking:


@scrolls_mckenzie just try opening one of the projects I had forked in the read only editor in an incognito tab(this is quite important to avoid plugins) - https://playcanvas.com/editor/project/755734. If this works as intended, then it may be a script/plugin you have.

As i said… i have tried that but happy to try again. The result is the same. I opened your build as asked and here is the screenshot

also tried in multiple browsers so plugins are not the issue.

Ah, then it’s most likely a regional editor bug? I’ve asked a friend of mine in Australia to try too, he should be able to do it in a few hours.

another user in my office has checked the self hosted output and is not seeing the issue. Although its happening on every browser I have. I’m going to do a full reboot and check again and will happily eat my words if this works.

Hopefully this is machine error

1 Like


Machine issue. Somehow effected all my browsers.

I’d call it a n00b issue but that was very unexpected to have my video effected in all browsers like that. Happy for this topic to be removed as resolved

1 Like

Glad that you solved the issue! This looked like a video card issue. I’ve seen similar issues on my Mac at times when it wakes up from sleep and only a restart fixes it

working every day on Herbivore and never had a screen like this :slight_smile: So the issue is most likely eithin Your installation

I guess exactly the same issue when Mac overheats in the summer occasionally, but it’s not limited to Playcanvas app, but all 3d stuff in browser looks like this. I shut down the Mac for 5 minutes and all is good again after reboot.