Script swapping feature doesn't work anymore

It’s been several days, not sure exactly how many.
Scripts aren’t swapped anymore - actually the files aren’t parsed at all after saving them in the code editor.

Hi … thanks, we’ll investigate this. Any specific repro steps?

any script (event without the swap function) with just console.log(‘foo’) on the top level will do the trick. Updating the file in any way doesn’t output anything to the console

I just created a simple project and checked - hot reload worked ok for me. Perhaps it has something to do with your specific project? Are you able to add me to it so I can investigate?

I added you to this project:
Updating script.js file doesn’t propagate to the launch tab for me

strange, all works for me in a simple project. Is your script attached to anything?

Yes. But it’s a problem in all my projects. User subpixel on discord reports the same issue

Thinking if there is a browser extension or something hindering the communication between the two tabs.

@redka can you try on a different browser just for testing?

Just tried it on firefox with most of the extensions disabled and it doesn’t work.
Code editors communicate between sessions in real time as usual but seems like ctrl+s isn’t relayed to the editor/launch.

Found the issue, being addressed in Fix script hotreload by slimbuck · Pull Request #5462 · playcanvas/engine · GitHub