In the keepyup game example, as well as in other areas of playcanvas user manual/tutorials, I keep seeing naming conventions like
this._score
what is the reason for the underscore?
https://developer.playcanvas.com/en/tutorials/keepyup-part-three/
var Game = pc.createScript('game');
Game.attributes.add('uiMenu', {type: 'entity'});
Game.attributes.add('uiInGame', {type: 'entity'});
Game.attributes.add('uiGameOver', {type: 'entity'});
Game.attributes.add('audio', {type: 'entity'});
Game.STATE_MENU = 'menu';
Game.STATE_INGAME = 'ingame';
Game.STATE_GAMEOVER = 'gameover';
// initialize code called once per entity
Game.prototype.initialize = function() {
this._state = Game.STATE_MENU;
this._score = 0;
this.setResolution();
window.addEventListener("resize", this.setResolution.bind(this));
// listen to events from the UI
this.app.on("ui:start", this.start, this);
this.app.on("ui:reset", this.reset, this);
};