Publish hangs, possibly when big model included


I am able to repeat this issue. I imported a hi poly model form Humster3D and hit publish. So far the publish never completes after 5 minutes. It seems like the publish worked in that if I reload and go to the build page it seems ok ( not sure what surprised might lurk in the call stack ) so I think it might just be the UI losing its polling. I took a screen cast of the first 2 mintutes:


Here’s the project:


I downloaded the FBX in your project. Wow, 278MB! That is huge! I imported the FBX into 3DS Max and reexported it to FBX and got a file that is 71MB. A bit better. I dumped this into a new Model Viewer project and got this:

It took maybe a couple of minutes to convert. Nice model! Very high poly (so not very suitable for mobile), but nice! :slight_smile:

My project is here.

Thanks Will!

Thats what I suspected the issue was overall.

Your project looks ‘sick bro’. We may need to ask more questions about optimizing load times and models down the road. We primarily serve mobile web and in-App so optimizing for devices is a must and not something we are very skilled at with respect to 3D.

I just noticed you were asking about publishing rather than model importing. Sorry. :smiley:

However, I just tried publishing and that worked fine too.

Hmmm, weird. I’m not sure what could have been going wrong for you. That’s not a bug I’ve seen before. But the fact that the model is so detailed/large could be a factor.

Anyway, I hope the info on reexporting the FBX to a smaller file helps…


I was about to ask another question about that aspect next anyway. Your efficiency approaches telepathic!