Playing animation sequences on 3D Mesh (texture and alpha) | PlayCanvas x Zapworks

Sorry, I meant this tutorial project: PlayCanvas 3D HTML5 Game Engine

Oh there it always worked for me. It was on the github with all the examples it didn’t.

Any idea about the issue above where the video shows in the pc browser, but not on mobile?

From the earlier messages, I was under the impression that it didn’t work for you?

In regards to this example: PlayCanvas Examples

I’ve managed to reproduce it and will create a ticket to look into it: [Examples Browser]: Video texture doesn't play on Chrome Android · Issue #3311 · playcanvas/engine · GitHub

1 Like

Yeah on that link it doesn’t work, but on the tutorial link you send previously the video starts playing on the computer browser so no problem there.

I work on iOS and both Chrome and Safari have the issue it seems :slightly_smiling_face:

Does the tutorial project work for you on iOS Chrome and Safari (ie Tutorial: Video Textures - PLAYCANVAS)

If it does, can you work with the code supplied there?

Yeah I used the code supplied there and it does work for me, but from the moment I try to combine it with the Zapworks code (in an instant tracker) it doesn’t seem to show the video on mobile.

Do you get any errors in the browser console?

Only a WebGL render warning it seems: “RENDER WARNING: texture bound to texture unit 0 is not renderable. It might be non-power-of-2 or have incompatible texture filtering (maybe)?”

Currently using your footage from the rabbit.

If the video plays as expected don’t worry about that warning.

Yeah but the video doesn’t show on my iOS device (Iphone 12 Pro). A colleague of mine just tried the
filter on Android and says it works for him there. Says a possible solution might be to take of the sound of the video and put the video tag on muted.

Are you using the launch tab or a build when testing on iOS? If the the launch tab please note that it doesn’t work due to the way that the video is being served and Safari being a bit more secure. See MP4s can't be played in Safari launch page · Issue #265 · playcanvas/editor · GitHub

Please try with a build instead.

If I get time tomorrow, I will have a go with Zappar x PlayCanvas and see what is happening.

Building it did the trick! Forget you mentioned this before cause I thought it wasn’t an autoplay issue but thought it was an issue that it couldn’t load the video itself :sweat_smile: Strange that I had the same issue on chrome though.

A million thanks for the great help!

Fixed the engine video texture example: