Particle not play sometimes


this time, I make a small test scene to test the particle system. Here is the link : ParticleSystem.

There’s two problems.

  1. Particles not play sometimes.

2.Particles’ color will turn to white. Because of the transparent canvas, as you can see, the particle out of the road is becoming white.

Thank you for your time !

Hello ? Could anybody tell me why ?

Why nobody answer for this question?

I want to know the reason,too.

Hi WingUNO

Sorry about the delay, it’s been a busy week!

I had a look at the project and the reason why the particle effect doesn’t look like it is playing is because the particle effect is parented to the ball. So when the ball rolls, so does the particle effect due to the parenting effect (see pic).

This meant that the particle effect was sometimes playing in or under the floor.

I’ve forked the project here:

What I’ve done is unparented the particle effect from the ball, created a new script called ‘FollowBall.js’ and added it to the now unparented particle effect. All the script does is move the particle effect to where the ball is in the XZ plane.

Not sure what is causing the odd ‘white out’ effect on the particle though. Need to look into that a bit more.

1 Like

Had a closer look into the particle white out problem and ultimately it is due to the way that the particle alpha blending works. As the canvas background is set to be transparent in the scene/project settings, when the particle is on top of the background, it does a calculation of the accumulative alpha which causes the white out.

Unfortunately, the way to ‘fix’ it is to put that background into PlayCanvas as an entity rather then as HTML.

1 Like

Hi, steven. Thank you so much. I need to test the particle system of my “big” project. In my “big” project, I also set the particle as child of the “ball” which is not a ball but a Box. And this Box does not rotate. That’s a little strange and I need to unparent the particle to the box to test. Thanks again, you are a big big nice guy. :grinning: