Lightmap object lose texture

Hello, i have enabled the lightmap on some object and it loose the texture, if i uncheck lightmap texture is back

Hi @ayrin,

Can you post your light and model component settings?

possibly related to this, try the workaround mentioned please

1 Like

Tried the suggested solution, it doesn’t work, here is the screenshots @Leonidas

Hi @ayrin,

Just to make sure, does your castle.json model contains a second set of UV coords (UV1)? Those are the coordinates used to map the lightmaps on a model.

If not, select that model asset in the inspector and press auto-unwrap:

Pressed it multiple times, pressed it again, but still no textures, if i disable lightmap textures get back

Can you prepare a simple sample scene with your lighting and 1-2 of your models that lose their textures?

This will help with debugging it.

Indeed I can reproduce the issue, enabling Use Metalness in your material seems to fix the problem.

Need to research a bit on this, why lightmaps don’t work with a plain diffuse-only material. @mvaligursky any idea?

1 Like

Yes @Leonidas with metalness at 0 it works unluckly the lightmap doesn’t affect my frame rate :frowning:

1 Like