Launch vs. Publish: somehow not the same

I recently forked your WebVR demo and tried to implement my tests using that as a base. Essentially I replaced models and left all your scripts and logic for webvr, 6DoF, teleporting and Gaze intact.

While launching from the editor I was getting a crazy amount of weirdness.

  • Failed to recalculate device parameters.
    -Error loading scripts. Open the browser console for details.
  • Gaze would work on certain areas of the floor and not on others
  • random crashes

I went on trying to debug that by basically enabling/disabling entities and seeing what happened, switching between OBB and AABB on the parameters for shape.js script, turning everything off and turning it back on one by one. Those are 5 hours of my life I will never get back… but, one of the last tests I did was to open the original published WebVR demo, and of course no errors… but it occurred to me to check the Launched version of that demo. So I went into the editor and launched (the original demo, not my fork), and there it was: same errors.

So I went and published my test and all the errors were gone!


The only thing I can think of, is that there are additional scripts that are attached to the published version vs. the launched debug version.

I infer what most of the scripts in that demo do based on their name or a partial function-chasing (who calls who after what, and why?), so I wasn’t sure where to look to debug these, plus, I was only getting these errors on mobile which complicates debugging. [[ BTW: some documentation on those scripts would be GOLD ]]

Any thoughts?

The errors says: Open the browser console for details, have you done this?
You have not posted link to your project, nor you posted the actual error.

Please, check out topic on debugging:

That link goes into how to debug on desktop browser, which I have no problem with. Not sure how to debug on mobile (Android), and that’s the only place where I’m getting these.

Has anyone else tried to replicate this?

Debugging mobile browser is same, you just need to enable remote debugging (google it).