Is there some way to disable basis

I’ve followed the instructions in the user manual on how to disable basis, but now when I launch a preview none of my textures load and the console logs an error for every texture that I have. I found out I can’t use it because the scripts that run it use setTimeout or setInterval which won’t load on a page with a CSP where unsafe-eval is not allowed and android webview will not let a page specify unsafe-eval in the csp. Also besides the launch preview I think it messed up something in shader, because when I download it and run it in an android emulator the legacy textures load, but some scripted emission effects aren’t working.
The bad launcher build can be seen here DF prototype - PLAYCANVAS

Did you remove the basis compression from each individual texture before removing the basis module?

No, but then I re-imported basis and unticked them
I suppose I could try deleting all the textures and re-implementing them because the other option is to rebuild the whole project and that would take me literally a week if I’m lucky.

Whenever you untick the basis checkbox, you need to reclick the compress button. This will actively remove the basis textures from that asset.


Ok, I’ll keep that in mind for next time. I have got the issues fixed by reuploading I just recently found out that limitations with the CSP.