Input problems with autocomplete

Hi, I’m having problems with the input of my project. It turns out that I put the attribute of ‘autocomplete’ and leave its value in ‘off’
But still, autocomplete doesn’t go away. Could anyone know a way to solve this dilemma?
Thank you very much already

Hi @Immolated,

Are you using an HTML input attribute? Normally what you are doing, if there isn’t any bug, should work.

Check this article for a more in-depth explanation on how that attribute works and where it should be used (this isn’t PlayCanvas related directly):

I have read the post, I am attaching the link of the script so that you can observe, because I cannot identify any errors.

Your code seems correct. Have you tried to inspect your input element using the browser dev tools to see if the attribute is there?

1 Like

Honestly, I don’t know how to inspect it.

Here is a nice guide to start with:

Sorry, I already found it and if it has the attribute assigned as well as the value, but the problem persists

What are the steps to reproduce this in your project?

Sorry, I can’t understand what you mean. The translation is not being very clear

I mean after I launch your project how do I test the problem you have. Which input has autocomplete right now enabled.

Ohh, I understand.
When the project starts, the first input is for a nick, it is after clicking the button and connecting that the chat input appears. When I put a slash ‘/’, autocomplete options appear and I want to avoid this

Does this issue happens on desktop or on mobile?

Gave it a try on desktop/chrome and even after typing the same things, and after reloading the page, I don’t see any issue with the field.

I checked with the inspector and the attribute is in place.

As I said, if you start by typing the ‘/’ character, autocomplete options appear. Otherwise the options do not appear

I am not able to reproduce that.

Unfortunately for me if I get the autocomplete option
Sin título

That’s on desktop or mobile? What browser is this running on?

Not sure what will force that.

It’s desktop computer, and the browser is Edge

Right, it seems this is a particular problem with that browser. Doing an internet search I came up with this stackoverflow post.

There are some suggestions you can try:

I understand, thank you very much for taking the time to read and respond. I’ll see how it goes.
Kind regards

1 Like

Just wanted to note here that browsers are starting to push back against the use of autocomplete prevention as it is seen as more secure than typing (think password managers). While you might find a fix today, it may stop working the the future updates of different browsers. Your best bet is to let your input fields be compatible with autocomplete.