[HELP] Can't overwrite assets


I can’t overwrite my assets in my project, whenever I try to I get this error:

This forces me to delete all the assets in my project in order to reimport them, causing me to lose all my materials and other important stuff

Can anyone help me with this?

  • This happens in all browsers
  • I’m trying to overwrite FBX files from 3ds max
  • This also happens to other assets such as images or materials I try to overwrite

Hey, is it possible you drop here both FBX, old and new, so I can replicate the scenario?
Is it materials not updating properly, or geometry not changing, or what exactly not overriding?

I’ve tweaked some settings the way existing materials getting remapped to changed models, check now if problem persists. If it does, then please give more specifics, and troubling assets.

Unfortunately, I’m not allowed to share the fbx file with you, but I tested with random objects here and all of them give me the same error when I try to overwrite a model.

The problem is that I get this error and the build won’t run anymore and I can’t change anything in it until I delete everything and upload it again. It happens everytime there’s a change in the geometry.

Hi thepariah6.
Could you please make a primitive model that has same problem, that you will be able to share?
I still cannot reproduce the problem here, it might be related specifically to your models.

Okay, so here is what happens:

Let’s say this cube is the model I’m working with:

I upload it and set all the shaders and stuff I want…

Then my boss comes to me and say: “We need to put two spheres on top of that cube”

Then I go and add the spheres, save the file with the same name to overwrite it in the project:

After the upload, whenever I try to run the project I get the error I showed in the original post and I’m forced to delete the model and the materials to continue working.

I see the flow.
If you could share permissions to download those two files so I could download them please.

Thank you very much for making example, once can reproduce, we will fix it asap.

*This happens all the time, I don't know why I can't share links some times.*

*I tried sharing the models folder... see if it works:*


EDIT: The files should be shared now, I just received the email.

Hi again.

Thank you very much for sharing troubling models.
I’ve made a fix and deployed already. Just refresh your editor.
Apologies for inconvenience, and thank your for collaborating on fixing the problem.


I love playcanvas support team, you guys are awesome
Thank you very much for you time and attention


1 Like

I’m sorry for bumping this topic but I’m having the same problem once again, it was fixed at first but moving on with the project I can’t overwrite my assets anymore.


Sorry to hear that. I’ve tested with assets I have here, and it seems ok.
Could you give troubling assets or if you can’t share them, do you have simplified example of another assets that lead to the same problem?
Would be very appreciated.


It seems to be a problem overwriting animation in my assets…

If I delete all the animations from the project the error goes away, but once again, I end up losing some work time


Also, these weird icons appeard in the middle of the screen, don’t know if the problem is related to them or not

Question marks and a man running

1 Like

Deployed fix for animation. Re-uploading model with animation, should fix the problem.
This icons appear for entities without model component but with other components.

For convenience of picking them in editor. They are not seen in launch.
And if they bother you, then you can set Icons Size setting in Scene Settings to 0. This disables icons.

I’ve noticed that smoothing groups (normals) on buttons are a bit funky on that model.
Nice material plastic material. You are using PBR here? :slight_smile:

You help in fixing those problems is very appreciated.

1 Like

There’s actually a normal map that fix that weird looking buttons that I haven’t applied since I re-uploaded the model :smile:
For the plastic I’m using the physical shader with a prefiltered cubemap and a normal map :smiley:

Thank you once again for your time fixing my problems, I’ll test it out and give you some feedback if something else goes wrong


Normal maps do help out, but usually normals on vertices should not have that problem in first place.
This model looks good.

This is not “your” bugs, but actually mine :smiley: and do affect many other users, but problem is that many of them do not report about it. So thanks again for collaborating.

1 Like

Haha I get it, thank you…

Just tested out here and overwriting is working fine again :smile:


1 Like