Failed to Execute 'getShaderParameter' on 'WebGL2RenderingContext'

I have been getting this error for a few weeks.

Every time this happens, the editor ‘crashes’ and the editor view turns black. This happens every 3-4 minutes or so on all browsers (Chrome, Brave, Safari). Reloads and system restarts only offer a temporary fix, as the same error comes back within 5 minutes.

I have a MacBook Pro 2018 and below are the system specs.
Screen Shot 2023-02-19 at 12.04.18 PM

1 Like

cc @mvaligursky

I wonder if some memory leak takes place and webgl runs out. Could you please try Performance Monitor in Chrome, or similar build in memory monitoring, to see if that is the case?

In the meantime, can you try disabling one or both of these options in the Editor Settings (Camera Depth Grab especially) to see if it helps?

Otherwise, please use Firefox or Safari while we investigate

Can you also try running PlayCanvas Examples

And screenshot what you get in the bottom right? It should look like this:

While I’ve notified @Krish_USCan, and we can wait for him to try these, I believe non-Chromium browsers were also not working (see below). Hopefully your suggestions can solve it.

Hmm, Surprised that Safari had the issue :thinking: Can you also try Firefox please?

Hi @yaustar sorry for the delayed response. The main issue I am currently facing is replicating the issue. I worked on the editor for around 20 minutes on Chrome today without any changes to the Editor Settings as you suggested and did not face any errors.

I also ran ‘PlayCanvas Examples’. The bottom right box is plain white.

I have changed the Editor settings to what you suggested as of now and will let you know if the error persists but until today I have not faced any difficulty.

I will also be trying what @mvaligursky advised.

1 Like

@Krish_USCan Thank you for the feedback and looking at the PlayCanvas Examples, all this information helps a lot

@Krish_USCan Did you manage to find a combination of settings that fixed the issue for you? We are looking at whether these options help and if we should remove them

@yaustar I haven’t had the issue since so I am hoping that these settings helped. Will re-open the topic in case the error pops up again. Thanks so much for the help.