Error when importing project

I’ve got an exported project that I’d like to import into playcanvas, but during the import I get an error saying it’s missing hashes.json. From what I can tell, the issue is caused by unzipping and rezipping the project folder, as I can export a different project and import the zip correctly, but if I unzip that project and zip it again I get the same error. Unfortunately I don’t have the original zip file for the project I’m trying to import so I need to be able to rezip it.

I’m doing this on osx with the default zip utility, I can try doing it on windows as well to see if the error still occurs.

Hi @Tyler,

I haven’t tried to import a file that went through unzip/zip, not sure what the issue may be.

Invoking @yaustar @vaios to help on this.

To cross check, can you post a screenshot of the files on finder that you are zipping and trying to import.

Also, are you right clicking on the folder and archiving it or are you selecting all the folder contents and archiving it?

This is important as the first option also includes the containing folder as part of the zip (at least on OSX, I’ve been bitten by this before)


Ugh yep that was the issue. I forgot osx automatically creates a folder when you unzip and assumed it was part of the project. Thanks for the help!

I’ve been there. Spent an hour trying to work out what was wrong with a different uploading tool. :frowning:

1 Like