Entity Transparency Related Issues


The value of “material_opacity” has been adjusted to give an effect that the entity becomes transparent after colliding with another entity.

meshInstances[i].setParameter("material_opacity", alpha);

However, as it becomes transparent, even the wooden floor becomes transparent, you can see the grass floor.

Can we solve this problem?

Hi @issactoast,

That’s quite strange. Can you share the settings of your material? What blend mode are you using?

1 Like

I’m sorry, but what kind of settings should I share?

If you are able to share a sample project that reproduces the issue that would be best.

Normally setting alpha to 0.0 will make the mesh fully transparent. Seeing what you get I am puzzled what the issue may be, so we need more info to help you out.

1 Like


It’s a temporary project.
The same thing happens in that project

I see, any reason the GreenGround and New Material materials have opacity set to Alpha? I don’t see they have any transparent parts. Since they are quite larger compared to the Arrow object they make it difficult for the engine to sort them.

Try setting the Blend Type to none for those two materials and try again.


I set it up wrong… :smiling_face_with_tear:

Thank you for helping me solve the problem. :upside_down_face:

1 Like