Engine Release: v1.63.0

Engine v1.63.0 has been released. Release notes:

To stay updated on engine development, hit Watch on the repo. Support us by hitting Star too! :smiley:

9 Likes

Please note that with 1.63, Draco WASM is now downloaded and compiled when it is first used in the engine (similar to Basis)

Therefore, if you are testing 1.63 in the Editor, you will see Draco being downloaded and compiled twice unless you disable preload on the Draco WASM in the Editor.

See this ticket for more details: v1.63.0 forces draco re-download when initializing workers · Issue #5307 · playcanvas/engine · GitHub

1 Like

This is really good for game makers, thanks

Testing v1.63.0 on an existing editor project that uses Draco compressed meshes and I’m getting the following error multiple times:

image

1 Like

Hi @Leonidas,

Is it possible to add me to the project?

Thanks

1 Like

Would you have some simple repro for this? I tried to repro this but no luck. It seems you’re using a Model Component, which is what I used, with different materials / mesh preloading options.

I’ve reproduced the error here: 1.63 TypeError: Cannot read properties of undefined (reading 'alphaToCoverage') · Issue #5313 · playcanvas/engine · GitHub

We’ve rolled back the editor release to engine 1.62 and the previous editor code
We will investigate all issues reported for a new editor release

1 Like

I’m updating a project for 1.63.x and one error I’m encountering is the following, in the debug view (also for a built instance), introduced with 1.63.x (pretty sure 1.63.0):

f6e8c841-d034-4343-a001-f8803fc363e1:268 instantiate failed + LinkError: WebAssembly.instantiate(): Import #11 module=“env” function=“memory” error: memory import must be a WebAssembly.Memory object

Thrown from the DracoWorker’s init case

I notice that @yaustar 's Draco example project here is exhibiting a similar error from the debug view, and it was also introduced with 1.63

instantiate failed + LinkError: WebAssembly.instantiate(): Import #11 module=“env” function=“memory” error: memory import must be a WebAssembly.Memory object

I’m wondering if anyone has a solution for that error?

Hi @3dTim , I’ll investigate and keep you posted.

1 Like

I encountered a weird issue with the 1.63.0 version. I had pre-assigned a material mask in the inspector settings, and this worked perfectly with earlier versions of PlayCanvas. However, with new version, the mask just rendered a white square.

I needed to make a script where I assigned the material to the Material slot through script instead of doing it in the inspector. Then it started worked again. Weird.

Hi @eivind,

Do you have a repro project that you can give us access to? If so please add slimbuck to the project. This’ll help us find and fix the problem.

Thanks!

Hi @3dTim,

It turns out the project had swapped around the “glue” and “fallback” script. That’s been fixed now and you should make the same change to your project.

Thanks!

1 Like

Confirmed. Thanks!

image

Using the 1.63.2 and 1.63.3 versions of the engine will result in this error message, and the loading page will remain at 99%, while the 1.62.2 version will display normally
The place where the problem occurred is the same as 3dTim’s

Hi @leooooooo,

Did you see my message on why the error was happening and how to fix it?

The glue and fallback scripts were reversed in the original project. If your project does something similar then you’ll have to fix it by swapping them around.

The draco wasm module should look like this:

Thanks!

Ammo and Draco? are these names supposed to be a message? A message that the creators of PlayCanvas slide on opps? (Please dont ban me lol)

Does anyone have thoughts on why meshopt stopped working in 1.63?

I’m getting this in my project:
image

As an example project, this one exhibits the same error, also introduced with 1.63.

A simpler example: dropping a meshopt-compressed GLB in the Model Viewer (using 1.63.3) produces the same error. Such a GLB can be downloaded from the above project.

I see the same behaviour with the viewer and few of my meshopt files. We’ll investigate on Monday.
@slimbuck

1 Like