Dynamic Batching Bug

Hey, I just discovered this bug on firefox android:

Steps to reproduce,

  1. Use dynamic batching on any object
  2. Disable the option (Prefer Webgl 2.0) from the rendering tab
  3. firefox android browser wont show the batched object.

Link to test: https://playcanv.as/b/t1vhGV6d/

Confirmed, I can reproduce this, thanks @Geniteam for reporting this. This is definitely a bug, hope not for a missing Firefox for Android feature.

I am submitting an issue about this on the engine repo.

1 Like
1 Like

I tried this on Sony Xperia Z from 2013 using Android 68.9.0 and dynamic batching works well.
Perhaps there was fix in Firefox, and also engine code for batching has changed considerably.

Please let us know if you can still reproduce the issue on your device.

1 Like

Confirmed, the issue seems to be fixed, testing on the same device.

Thanks for looking at it @mvaligursky.

Tried the above link on my Android phone with the latest firefox browser, and I dont see the batched objects (they are visible in chrome).

Device name: Honor 8X model: JSN-L22
Android version: 10
Firefox version: 68.9.0

thanks @Saad_Haider. Could you also try http://playcanvas.github.io/#graphics/batching-dynamic.html on your device please.


Yes that works fine

@mvaligursky I made a build of my game which uses alot of batching, its not working, maybe some issue with batching not working when done through the editor?

This is the build ( made 2 days ago) and you can check the difference when running on chrome vs firefox.

On my Pixel 3 and very old Sony Xperia Z, you game works fine @Saad_Haider, I cannot reproduce the problem in the Firefox :frowning:

Game on Firefox, and the game is very slow, referring to this thread: