Does XR works with Ocuclus Rift?

Hello guys,

Just a quick question, would playcanvas works with oculus rift S headset? I tried to use my Rift S but it is not working. Does playcanvas only works for mobile headset like the Oculus Quest, or googlecardboard?

Thank you

Hi @dongqtm,

No it should work perfectly fine with the rift s.

What error did you get? Make sure to have your Oculus OS updated to latest version when trying a Web XR Playcanvas build.

You may also need to enable WebXR in the browser flags on PC too.

I’m currently working full time with the WebXR module of Playcanvas. I use the HTC Vive Pro and Firefox Reality browser for easy and fast testing + Chrome WebXR Emulator for debuging.

@dongqtm I’m pretty sure you can do the same thing with your HMD. Which WebVR browser are you using with your Oculus Rift?

So what I did was that I connected my rift s to my computer, then open google chrome on my computer using the rift s, then I used the “trigger button” on my right controller to click on the button that supposed to launch the game in VR, but nothing happened. I tried this in the Quest and it works. Maybe it is something in the code that I am doing wrong? This is how I coded it:

Thank you guys!

Have you checked if return true with your Rift? If it’s false, your button should be inactive and not clickable.

Also, can your verify if you can launch this immersive-web demo using your Rift and Chrome?

Another test you can do is trying with Firefox Reality to see if the problem come from the browser.

Oh, be sure to always uses HTTPS as protocol, otherwise WebXR is impossible.

Hi Mystik, returned false for my rift, however I tried removed that piece of code and it still doesnt work.

Also I tried the immersive web demo and it also doesn’t work. I tried that on chrome.

So now I don’t knnow if it is something due to my Rift S set up. How do you set up yours?

Thank you

This piece of code is important and if it return false, it’s because the problem came from outside of your project, so the problem is probably your setup.

In my case, I got similar problems with Chrome + HTC Vive. That’s why I use Firefox Reality actually.

Note that the WebXR API is still in development so it’s also normal that few browsers support it from end to end.

I have noticed that I got this problem after I installed the WebXR device emulator extension on my chrome and firefox. Did this also happen to you?

I didn’t have any problem with WebXR device emulator, except the fact that it can’t emulate all the buttons.

Did you tried without the emulator if it’s the cause of your problem?