Dark edges on the model where the UV seams are

I have an issue with how the objects get this dark edge right where the uv seam is => 1.

I make textures that are pixel-perfect, and the point is to make them as small as possible, thats why my UVs don’t have any padding inbetween them.
I indeed can solve this just by making a 1px margin overflow like this => 2.

But it ruins my workflow and leads to unnecessary mendling with my textures.
Is there a way resolve this issue without adding any padding, as it works fine in other engines like Unity for example => 3.

Can you provide a small project to look at please? It might be related to mip maps


I also discovered that if i turn off antialiasing in the settings the problem seems to go away, but only at Launch, in the viewport it’s still the same =>

Any ideas @mvaligursky ?

Hi, any updates on the issue ?

I spoke to the graphics team and they believe it’s related to this issue: GLSL: Center or Centroid?  (Or When Shaders Attack!){/exp:channel_entries}

We don’t have clear answer beyond the workarounds you have found so we will add this as an engine bug/issue for now until the team can potentially investigate it.

Offhand, it may require a shader override?

Ticket: https://github.com/playcanvas/engine/issues/4573

I hear you, ok, thanks for consideration. :wink:

Hi @Taras_Bunych,

Disabling multisampling in your app fixes the issue so enabling centroid sampling will likely fix the problem.


(You can disable multisampling using the ‘Anti-Alias’ option under rendering settings).

Yeah, thanks, and to keep the antialiasing i just used your code for FXAA from github =>

and it works like a dream. Here’s an example =>

I just hope it isn’t very resource hungry. :slightly_smiling_face: