Collision component does not render in new editor

Hi, When I add a rigid body component it shows up on the designer as expected. Now when I add a collision component to it that does not show up ? How can I adjust the half-extents like we used to do in the old editor please and thanks.


I can’t seem to reproduce the problem. When I add a new collision component to an Entity I see a box inside the editor. I can change the half extents using the Inspector on the right. The rigid body component does not have a visual representation in the editor - only the collision component does.

Can you maybe give a link to your scene maybe there’s another problem.


Hi Vaios,
I was testing the new editor and all I have is a cube that has rigid body and collision components but as the embedded image will show you all I see is a visual represenation of rigid body but no collision component ?

The link as requested is here:

Am using Debian with Iceweasel if that helps any, I tried Chrome same issue. Thank you.

And this image will show you I have added both components on the menu. As the collision and rigid body components are greyed out.

Does the collision component appear if:

  1. you select another entity and re-select the Box?
  2. you refresh the page?

HI Dave,

Tried what you had suggested but problem still persists, no collision component appears.


Hmm, are there any errors in the javascript console?

Yes it says SyntaxError: property name enum appears more than once in object literal. Please see embedded image for details. Thanks.

Ah OK this is a problem in our scripts that usually seems to be fixed with the latest version of browsers. Can you update your browser to the latest version and check again?


OK, this is bug in the editor. We’ll deploy a fix, but I think it actually works with a later version of Chrome, so you could try updating. Or wait until we’ve fixed it.

Sorry about that.

OK I deployed a fix for this can you please try again @Aruna_Hewapathirane ?

Hi Vaios and Dave,

I updated chrome to the latest Version 40.0.2214.115 (64-bit) and it tells me:

VM3191 attributes-components-collision.js:107 Uncaught SyntaxError: Duplicate data property in object literal not allowed in strict mode

Can’t we turn off ‘strict’ mode ? Or is that a bad idea ?


Hi Vaios and Dave,

It’s working now. Many thanks people :thumbsup: