''Cannot read property 'isSupported' of null'' in VR

hi all,

since friday I keep getting this error message in playcanvas console: ‘‘Cannot read property ‘isSupported’ of null’’ (like this one Cannot read property 'isSupported' of null) in all the projects in VR, therefore I cannot open them with the headset. Anyone has a clue of what’s happening? I thought it could be a internal error or update of the VR engine for playcanvas, idk.

thanks in advance!

@yaustar any clue? all my projects in VR are presenting this error, even though I haven’t touched them in a long time.

Seems like this is the same issue:

AFAIK, the WebVR support was decoupled a month or so back and the editor now has support for loading external scripts (added to the script header in the HTML). This allowed users to now use the latest version of WebVR polyfill. This was the intention but I don’t know why the older demos are broken.

I’m having a quick look now to see if I can get something working but hopefully someone from the team can give a better answer when they get into the office.

I now have something working: https://playcanvas.com/project/637555/overview/webvr-hello-world

It’s not perfect nor am I sure it’s the right way to do it but it gets you started.

@vaios Is this something that you can help with?

I tried that and it works on desktop and VR but the mobile view gets messed up. :frowning:

@yaustar @vaios any update on this issue?

@isabelaimufo (Just to be clear, I don’t work for PlayCanvas :slight_smile: )

There was another thread on this and I’ve tried an updated version of the VR Starter Kit here on Android Chrome which worked fine in Google Cardboard from my limited testing: https://playcanvas.com/project/435780/overview/starter-kit-vr

@yaustar oh, i thought you were, sorry about that.

it works partially, when the screen view is rotated to horizontal the scene gets tilted. how to solve that?


It does that in the simulated mobile browser. It works fine on the actual mobile device with Chrome AFAIK.